MOS Access 2013 Quick Reference

Exam 77-424: MOS Access 2013 Objectives
http://www.microsoft.com/learning/en-us/exam.aspx?id=77-424

Create a New Database

This objective may include but is not limited to:
o Creating new databases
= Open Access 2013 > Click option such as Blank desktop database > Choose file location = Enter
file name > OK > Create
o Creating databases using templates
=  Open Access 2013 > Search for a template OR click on one already visible that has “desktop” in
the title > Choose file location = Enter file name - OK - Create
o Creating databases in older formats
*= Open Access 2013 > Click option such as Blank desktop database = Choose file location - Enter
file name > Select file format from Save as type drop down list > OK - Create
o Creating databases using wizards
= This has largely been replaced by the three methods mentioned above and Application Parts
(shown later in this guide).

Manage Relationships and Keys

This objective may include but is not limited to:
o Setting primary key fields
= Open table in Design View > Click field > Table Tools: Design tab = Tools group = Primary Key
button - Save and close table
o Setting foreign keys
»= There is no "Foreign Key button.” Just ensure that you have a foreign key in another table. It is

often the linking field in the "Many” table of a one-to-many relationship as is the case with
ARTIST_ID in the tables below.

ARTIST ALEBUM
¥ ARTIST_ID L ¥ ALBUM_ID
ARTIST_NAME ALBUM_TITLE
ALBUM_YEAR
ALBUM_GEMRE
ARTIST_ID

o Viewing relationships
» Database Tools tab - Relationships group = Relationships button
o Creating and modifying relationships
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* Open Relationships window > Display tables = Drag from primary key field in one table to
foreign key in second table > Create
o Enforcing referential integrity
* Open Relationships window - Double click join line between tables - Check Enforce Referential
Integrity - OK
o Editing references between tables
* Open Relationships window - Double click join line between tables > Click additional
checkboxes if desired = Click Join Type to adjust join properties if necessary = Click OK on all
boxes

Navigate Through a Database

This objective may include but is not limited to:
o Navigating to specific records
* Find navigation at bottom of table, query, or form - Click buttons to move from record to record

OR enter a search term
Recard: M 1of6 F Mk Search

o Setting a form as the startup option
* File = Options = Current Database > Application Options section = Display Form - Choose
form > OK
o Using navigation forms
» Create tab > Forms group = Navigation button - Select one - Drag objects (such as forms and
reports) to the Add New area
o Setting navigation options
* File > Options = Current Database = Navigation section = Navigation Options button > Make
changes > OK - OK
o Changing views
* Drop down arrow on Navigation Pane controls view of objects in that pane
= Open object such as a table > Home tab - Views group = View button - Select view

Protect and Maintain a Database

This objective may include but is not limited to:
o Compacting databases
* File > Info > Compact & Repair Database
* File > Options = Current Database > Application Options section - Compact on Close - OK
Repairing databases
* File > Info > Compact & Repair Database
Backing up databases
* File > Save As - Save Database As - Advanced section - Back Up Database - Save As button
- Choose file location - Edit file name if necessary - Save
Splitting databases
» Database Tools tab - Move Data group > Access Database button - Split Database - Choose
file location = Split > OK
Encrypting databases with a password
* Close database = Open database exclusively (File > Open = Computer > Browse > Click on file
- Drop down arrow on Open > Open Exclusive) = File = Info = Encrypt with Password = Fill
out Set Database Password box - OK

o

o

(@)

(@)
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o Merging databases
» External Data tab > Import & Link group = Access button > Browse for file > Select Import
tables... option > OK - Select objects on various tabs = Click Options > > = Set options > OK
- Close
o Recovering data from a backup
» External Data tab = Import & Link group = Access button - Browse for backup database file >
Select Import tables... option > OK - Select objects on various tabs - OK - Close

Print and Export a Database

This objective may include but is not limited to:
o Printing reports
* Double click report = File = Print = Print - Set options if necessary > OK
Printing records
* Double click table = File = Print > Print = Set options if necessary - OK
= If only selected records are needed, highlight them. Choose Selected Records in the Print dialog
box.
o Maintaining backward compatibility
= File > Save As - Save Database As - Database File Types section > Select format - Save As
button = Choose file location = Enter file name - Save
o Saving databases as templates
» File > Save As - Save Database As > Database File Types section > Template - Save As button
- Fill out Create New Template from This Database box - OK - OK
= Templates are saved by default to:
C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Templates\Access
o Saving databases to external locations
= One option for an external location could be OneDrive (instead of saving to a flash drive or the
hard drive.).
» File > Save As - Save Database As > Advanced section - SharePoint > Save As button - Fill
out remaining dialog boxes
o Exporting to alternate formats
= Right click object (table, query, form, or report) = Export - Select format - Set options and
follow steps in wizard

o

Create a Table

This objective may include but is not limited to:
o Creating new tables
» Create tab > Tables group = Table Design button - Enter field names, choose data types, set
properties at bottom - Save and close table
o Importing external data into tables
» External Data tab > Import & Link group = Choose format (such as Excel or Text) = Browse for
the file > Read wizard screens carefully to set correct options
o Creating linked tables from external sources
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* External Data tab > Import & Link group = Excel, Access, ODBC, or Text button > Browse for file
- Link to the data source by creating a linked table - Read wizard screens carefully to set correct
options
o Importing tables from other databases
» External Data tab > Import & Link group = Access button > Browse for file > Import tables,
queries, forms, reports, macros, and modules into the current database - Select table(s) > OK >
Close
o Creating tables from templates and application parts
» Create tab > Templates group = Application Parts button - Select option (e.g., The Contacts
option will insert tables, forms, reports, and a query.)

Format a Table

This objective may include but is not limited to:
o Hiding fields in tables
= Open table in Datasheet View - Right click field heading = Hide Fields
Changing data formats
= Open table in Datasheet View > Select field > Table Tools: Fields tab > Formatting group = Set
Data Type and Format
Adding total rows
= Open table in Datasheet View > Home tab = Records group = Totals button = Choose function
for desired field in Totals row
Adding table descriptions
* Right click table = Table Properties = Enter description - OK
o Renaming tables
* Right click table - Rename = Enter new name - Press Enter

O

O

O

Manage Records

This objective may include but is not limited to:
o Updating records
= Open table in Datasheet View - Scroll to record to update - Click in the appropriate field > Edit
data > Press the down arrow on the keyboard to move to the next record to save the edited data
o Adding new records
»= Open table in Datasheet View - Home tab = Records group - New button - Enter data >
Move to next record to save
o Deleting records
*= Open table in Datasheet View = Select record > Home tab - Records group = Drop down
arrow on Delete button - Delete Record - Yes
o Appending records from external data
» External Data tab > Import & Link group > Click appropriate type (e.g., Excel or Text) = Browse
for file > Append a copy of the records to the table: <Choose table> > OK - Follow steps in
wizard
o Finding and replacing data
= Open table in Datasheet View - Click appropriate column = Home tab - Find group - Replace
button - Fill in Find What and Replace With = Set other options = Replace OR Replace All >
Yes = Close box

MOS Access 2013 Quick Reference 04/23/2014 Page 4 of 11



= Example: You are given a BIRD table with a COLOR field. The color field contains various
instances of the following: red bird, blue bird, black bird, yellow bird. You must use find and
replace to remove the space and the word bird ( bird) from the entire field.
> Find What: bird <include the space before bird>
> Replace With: <leave blank>
> Match: Any Part of Field
> Replace All
o Sorting records
* Open table in Datasheet View - Click appropriate column - Home tab - Sort & Filter group >
Choose a sort
o Filtering records
* Open table in Datasheet View - Click appropriate column - Home tab - Sort & Filter group >
Filter button > Set options - OK
= Toggle Filter button will turn the filter off (NOT clear it).
= Click the filter icon in the field heading to see the option for clearing the filter.

Create and Modify Fields

This objective may include but is not limited to:
o Adding fields to tables
*= Open table in Design View - Click in empty row - Enter field name, choose data type, set
properties at bottom - Click row selector and drag to reposition field if necessary - Save and
close table
* Notice the various properties in the Field Properties section at the bottom of the screen. Various
properties will be on the test.
o Adding validation rules to fields
= Open table in Design View - Click field = Enter Validation Rule and Validation Text in properties
at bottom - Save and close table
= Example of Validation Rule for GRADE_TYPE would be: ="EXCELLENT" Or "AVERAGE" Or
"FAILING"
= Example of Validation Text for GRADE_TYPE would be: Enter EXCELLENT, AVERAGE, or FAILING for
GRADE_TYPE.
o Changing field captions
= Open table in Design View - Click field > Edit Caption property at bottom - Save and close
table
o Changing field data types
* Open table in Design View - Click field > Change Data Type (beside of field name) - Save and
close table
= If creating a Lookup field, choose Lookup Wizard for the Data Type, and follow the steps in the
wizard. Properties for the Lookup field can be tweaked using the Lookup tab in Field Properties.
o Changing field sizes
*= Open table in Design View - Click field > Edit Field Size property at bottom - Save and close
table
o Configuring fields to auto-increment
= Open table in Design View > Add new field with AutoNumber Data Type = Ensure that
Increment is chosen for the New Values property at the bottom = Save and close table
Setting default values

(@)
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*= Open table in Design View > Click field > Edit Default Value property at bottom - Save and
close table
o Using input masks
*= Open table in Design View > Click field > Click Input Mast property at bottom > Click the ellipsis
for it > Choose an input mask = Follow the steps in the wizard - Save and close table
*= Custom input masks can be entered directly in the Input Mask property box if an input mask is
needed for something not available in the wizard.
o Deleting fields
= Open table in Design View > Click field = Table Tools: Design tab = Tools group - Delete Rows
button = Yes = Save and close table

Create a Query

This objective may include but is not limited to:
o Creating multi-table queries
= Create tab > Queries group > Query Design button = Show tables at top of query design
window - Add join lines between tables if necessary = Drag fields to bottom of design grid
o Running queries
* Open query in Design View = Query Tools: Design tab = Results group = Run button
o Saving queries
* Click Save button on Quick Access toolbar OR File tab - Save As - Save Object As > Save As
button - Enter query name - OK
o Creating crosstab queries
» Create tab = Queries group = Query Wizard button - Select Crosstab Query Wizard - OK »>
Continue following steps in wizard
o Creating action queries
» Create tab = Queries group = Query Design button = Show table(s) at top of query design
window > Add join lines between tables if necessary - Drag fields to bottom of design grid -
Query Tools: Design tab > Query Type group = Make Table button - Enter table name > OK >
Run the query to build the table
* Make Table is only one type of action query. The others are covered in the article at this link:
http://office.microsoft.com/en-us/access-help/introduction-to-queries-HA102749599.aspx
o Creating parameter queries
= Open query in Design View = Show tables = Add fields to design grid = Click Criteria row in
field > Enter parameter such as [Enter GRADE_TYPE such as EXCELLENT, AVERAGE, or FAILING] >
Run the query
= To set a data type for a parameter: Copy parameter from Criteria row = Query Tools: Design tab
- Show/Hide group - Parameters button > Paste parameter in Parameter column - Choose
data type for it > OK = Run query - Save and close query
o Deleting queries
* Right click query - Delete > Yes
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Modify a Query

This objective may include but is not limited to:
o Renaming queries
* Right click query - Rename > Enter name - Press Enter
o Adding new fields
*= Open query in Design View - Drag fields down to design grid - Save and close query
o Removing fields
= Open query in Design View - Click field in design grid = Query Tools: Design tab = Query Setup
group > Delete Columns button - Save and close query
o Hiding fields
= Open query in Design View - Find field in design grid > Remove check from Show row - Save
and close query
o Sorting data within queries
= Open query in Design View - Find field in design grid > Choose Ascending or Descending in
Sort row - Save and close query
o Formatting fields within queries
= Open query in Design View = Click field in design grid = Query Tools: Design tab = Show/Hide
group > Property Sheet button - Update the Format property = Save and close query

Utilize Calculated Fields and Grouping within a Query

This objective may include but is not limited to:
o Adding calculated fields
*= Open query in Design View - Click Field row in new blank column in design grid - Enter
calculation such as: MARKUP: [RETAIL_PRICE]-[WHOLESALE_PRICE] - Save and close query
= Right click the Field row, and click Build if complex functions are needed.
o Adding conditional logic
= Open query in Design View > Right click Field row in empty column - Build = Enter IIF function
such as STOCK_WARNING: IIf(ONHAND_QTY]<2,"REORDER NOW!","Stock Level OK") > OK >
Run query - Save and close query
= Open query in Design View = Click in Criteria row of field = Enter something such as “Red” OR
“Black” for the COLOR field = Run query = Save and close query
o Grouping and summarizing data
= Open query in Design View = Query Tools: Design tab > Show/Hide group > Totals button (if
it's not already activated) - Choose expression in Total row = Save and close query
o Using comparison operators
= Open query in Design View > Click Criteria row for field = Enter a comparison such as >5 for
ONHAND_QTY - Run query - Save and close query
o Using basic operators
= Refer to adding calculated fields objective above.
= Other basic math operators include: + for addition, * for multiplication, and / for division. Review
the article at this link for more examples of operators: http://office.microsoft.com/en-us/access-
help/table-of-operators-HA010235862.aspx
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Create a Form

This objective may include but is not limited to:
o Creating new forms
* Create tab > Forms group = Form Wizard button - Follow steps in wizard
* Click object such as table > Create tab - Forms group = Form button - Save and close form
o Creating forms with application parts
= Create tab > Templates group = Application Parts button = Select form = Open it in Design
View to customize it > Save and close form
o Saving forms
» Click Save button on Quick Access toolbar OR File tab - Save As - Save Object As > Save As
button > Enter form name > OK
o Deleting forms
= Right click form - Delete - Yes

Set Form Controls

This objective may include but is not limited to:
o Moving form controls
= Open form in Design View = Drag controls to reposition them - Save and close form
Adding form controls
= Open form in Design View = Form Design Tools: Design tab = Controls group > More button >
Click control = Click area on form - Customize control if necessary = Save and close form
o Modifying data sources

O

» Open form in Design View - Click Form Selector '™ " in upper left corner - Display the
Property Sheet if necessary > Update the Record Source property - Save and close form
o Removing form controls
= Open form in Design View = Click on control = Press Delete key > Save and close form
o Setting form control properties
= Open form in Design View = Click on control - Display the Property Sheet if necessary - Click
the All tab > Update properties > Save and close form
o Managing labels
= Open form in Design View = Click on label = Display the Property Sheet if necessary - Click the
All tab = Update properties = Save and close form
» Labels can also be repositioned and resized using the mouse.

Format a Form

This objective may include but is not limited to:
o Modifying tab order in forms
= Open form in Design View = Form Design Tools: Design tab = Tools group = Tab Order button
- Select Section on left > Click selector for field - Drag to reposition > OK
o Auto-ordering forms
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= Open form in Design View = Form Design Tools: Design tab = Tools group = Tab Order button
- Select Section on left > Auto Order button > OK
o Formatting print layouts
= Open form in Print Preview - Print Preview tab - Page Layout group = Page Setup button >
Set options 2 OK
= Also note the other groups and buttons available on the Print Preview tab.
o Sorting records
= Open form in Form View - Click field > Home tab - Sort & Filter group > Select a sort
o Applying themes
*= Open form in Design View = Form Design Tools: Design tab > Themes group > Themes button
- Click theme (Right click theme to apply it to current form only)
o Changing margins
= Open form in Design View = Scroll to right = Drag the right border back to the left to make the
form narrower
= Open form in Print Preview > Print Preview tab - Page Layout group = Page Setup button >
Set margins > OK
= Open form in Design View = Form Design Tools: Arrange tab = Select controls = Position group
- Control Margins button
o Inserting backgrounds
= Open form in Design View = Form Design Tools: Format tab = Background group = Background
Image button - Browse for Image > OK
o Inserting headers and footers
*= Open form in Design View > Form Design Tools: Design tab - Header/Footer group - Insert
desired option = Move controls if they are inserted in the header but you need them in the footer
o Inserting images
*= Open form in Design View > Form Design Tools: Design tab > Controls group = Insert Image
button - Browse for Image > OK
o Modifying existing forms
* Review items in the Property Sheet for various areas of the form (header, detail, footer). Know
how to modify properties such as Caption, Back Color, Border Style, etc. for form sections and
form controls. The Property Sheet will update to show properties for the item selected.

Create a Report

This objective may include but is not limited to:
o Creating new reports
» Create tab - Reports group = Report Wizard button - Follow steps in wizard
» Click object such as table > Create tab > Reports group = Report button - Save and close
report
o Creating reports with application parts
» Create tab > Templates group = Application Parts button = Select a Quick Start option >
Depending on the option chosen (e.g., Contacts), various reports will be automatically created
o Deleting reports
* Right click report > Delete - Yes
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Set Report Controls

This objective may include but is not limited to:
o Grouping data by fields
= Open report in Design View = Report Design Tools: Design tab - Grouping & Totals group >
Group & Sort button - Use Group, Sort, and Total pane at bottom
= To make modifications, use the Move up, Move down, and Delete icons on right side of any
groups and sorts already inserted.
o Sorting data
= Open report in Design View = Report Design Tools: Design tab - Grouping & Totals group >
Group & Sort button = Use Group, Sort, and Total pane at bottom
o Adding sub-reports
= Open report in Design View = Report Design Tools: Design tab - Controls group = More button
- Subform/Subreport control = Follow steps in wizard
o Modifying data sources

»  Open report in Design View > Click Report Selector '™ " in upper left corner - Display the
Property Sheet if necessary = Update the Record Source property - Save and close report
o Adding report controls
= Open report in Design View = Report Design Tools: Design tab - Controls group = More button
- Select a control = Follow steps in wizard
= Open report in Design View = Report Design Tools: Design tab = Tools group = Add Existing
Fields button = Drag fields onto the report
o Managing labels
= Open report in Design View > Click on label - Display the Property Sheet if necessary - Click
the All tab - Update properties - Save and close report
» Labels can also be repositioned and resized using the mouse.
= There are also some formatting tools on the Home tab in the Text Formatting group. Those can
be used on various objects in the database, not just labels.

Format a Report

This objective may include but is not limited to:
o Formatting reports into multiple columns
» Open report in Design View = Report Design Tools: Page Setup tab - Page Layout group =
Columns - Set options - OK
o Adding calculated fields
* Open report in Design View = Insert Text Box control - Property Sheet - Right click Control
Source - Build = Enter formula - OK
o Setting margins
*= Open report in Design View - Report Design Tools: Page Setup tab > Page Size group >
Margins button - Select one
» Open report in Design View = Report Design Tools: Page Setup tab - Page Layout group -
Page Setup button - Enter margins - OK
o Adding backgrounds
= Open report in Design View = Report Design Tools: Format tab - Background group >
Background Image button - Browse for File > OK
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o Changing report orientation
*= Open report in Design View = Report Design Tools: Page Setup tab - Page Layout group =
Page Setup button - Page tab > OK
o Changing sort order
= Open report in Design View = Report Design Tools: Design tab - Grouping & Totals group >
Group & Sort button = Use Group, Sort, and Total pane at bottom
o Inserting headers and footers
* Open report in Design View = Report Design Tools: Design tab - Header / Footer group =
Insert desired option > Move controls if they are inserted in the header but you need them in the
footer
o Inserting images
» Open report in Design View = Report Design Tools: Design tab - Controls group = Insert Image
button - Browse for image - OK
o Inserting page numbers
» Open report in Design View = Report Design Tools: Design tab > Header / Footer group - Page
Numbers button - Select options > OK
o Applying themes
*= Open report in Design View = Report Design Tools: Design tab - Themes group - Themes
button = Click theme (Right click theme to apply it to current report only)
o Modifying exiting reports
= Open report in Design View - Various options on the four Report Design Tools tabs (Design,
Arrange, Format, Page Setup) - Display Property Sheet and modify properties
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